aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-09-04 14:44:10 +0000
committerJonas Gorski <jogo@openwrt.org>2015-09-04 14:44:10 +0000
commitb4003c5879bae0053c85b05e7c155800cf621bd6 (patch)
tree213390138fa45b7c74b414e6e3086c778ad5ec51 /include/image.mk
parentf80bb9040863bbfcb6f6cb82b145f3e1de92dc0c (diff)
downloadmaster-187ad058-b4003c5879bae0053c85b05e7c155800cf621bd6.tar.gz
master-187ad058-b4003c5879bae0053c85b05e7c155800cf621bd6.tar.bz2
master-187ad058-b4003c5879bae0053c85b05e7c155800cf621bd6.zip
image: add a build step for building and appending an ubinized rootfs
Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46783 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 73fc805bb5..fb89ed1222 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -345,6 +345,16 @@ define Build/append-rootfs
dd if=$(word 2,$^) $(if $(1),bs=$(1) conv=sync) >> $@
endef
+define Build/append-ubi
+ sh $(TOPDIR)/scripts/ubinize-image.sh \
+ $(if $(KERNEL_IN_UBI),--kernel $(word 1,$^)) \
+ $(word 2,$^) \
+ $@.tmp \
+ -p $(BLOCKSIZE) -m $(PAGESIZE) -E 5
+ cat $@.tmp >> $@
+ rm $@.tmp
+endef
+
define Build/pad-to
dd if=$@ of=$@.new bs=$(1) conv=sync
mv $@.new $@