aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-06-01 18:00:35 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-06-01 18:00:35 +0000
commit9f3ee855a6fa1a35bb3f3754ce44e33176177d19 (patch)
treee564e21eb78fb721ea720707fec811899286f06e /include/image.mk
parent434a7398621ae6c4a82eb89287d4359da523b271 (diff)
downloadmaster-187ad058-9f3ee855a6fa1a35bb3f3754ce44e33176177d19.tar.gz
master-187ad058-9f3ee855a6fa1a35bb3f3754ce44e33176177d19.tar.bz2
master-187ad058-9f3ee855a6fa1a35bb3f3754ce44e33176177d19.zip
include: image.mk: ensure that $(KDIR)/tmp exists in the IB case as well
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45870 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 36c6c63320..020418d54d 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -464,6 +464,9 @@ define BuildImage
image_prepare: compile
mkdir -p $(KDIR)/tmp
$(call Image/Prepare)
+ else
+ image_prepare:
+ mkdir -p $(KDIR)/tmp
endif
mkfs_prepare: image_prepare