aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-08-13 19:02:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-08-13 19:02:26 +0000
commit70648f53951e014bb852ac014e6baea05e6f3001 (patch)
tree472292da6b346cfabbbc970eea01634b72bb7507 /include/image.mk
parentc4298651230b299076d4a2157cd628f69e3017c9 (diff)
downloadmaster-187ad058-70648f53951e014bb852ac014e6baea05e6f3001.tar.gz
master-187ad058-70648f53951e014bb852ac014e6baea05e6f3001.tar.bz2
master-187ad058-70648f53951e014bb852ac014e6baea05e6f3001.zip
image: fix handling of per-device kernel build commands
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46589 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 470a5dafeb..9dfce111a6 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -424,6 +424,7 @@ define Device/Build/kernel
_KERNEL_IMAGES += $(KDIR)/$$(KERNEL_NAME)
$(KDIR)/$$(KERNEL_NAME): image_prepare
$$(_TARGET): $$(if $$(KERNEL_INSTALL),$(BIN_DIR)/$$(KERNEL_IMAGE))
+ $(call Device/Export,$(KDIR)/$$(KERNEL_IMAGE),$(1))
$(BIN_DIR)/$$(KERNEL_IMAGE): $(KDIR)/$$(KERNEL_IMAGE)
cp $$^ $$@
ifndef IB
@@ -439,7 +440,6 @@ endef
define Device/Build/image
$$(_TARGET): $(BIN_DIR)/$(call IMAGE_NAME,$(1),$(2))
- $(eval $(call Device/Export,$(KDIR)/$(KERNEL_IMAGE),$(1)))
$(eval $(call Device/Export,$(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2)),$(1)))
$(KDIR)/tmp/$(call IMAGE_NAME,$(1),$(2)): $(KDIR)/$$(KERNEL_IMAGE) $(KDIR)/root.$(1)
@rm -f $$@