aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-11 16:33:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-11 16:33:26 +0000
commit686b04f499b3f36aee0306d84c5321db98fb10c6 (patch)
tree7b73d71232e38584e9c9be6ea00d7077b702e904 /include/image.mk
parent2cd3a64073d504e8d4edf0370cf99b25a3ef1016 (diff)
downloadmaster-187ad058-686b04f499b3f36aee0306d84c5321db98fb10c6.tar.gz
master-187ad058-686b04f499b3f36aee0306d84c5321db98fb10c6.tar.bz2
master-187ad058-686b04f499b3f36aee0306d84c5321db98fb10c6.zip
include/image.mk: make tar reproducible
several packages reported different file order between builds make binutils, kmod-sched reproducible Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46859 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index cf6717cf19..c59222e415 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -245,7 +245,7 @@ define Image/mkfs/cpiogz
endef
define Image/mkfs/targz
- $(TAR) -czpf $(BIN_DIR)/$(IMG_PREFIX)$(if $(PROFILE),-$(PROFILE))-rootfs.tar.gz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
+ $(TAR) -czpf $(BIN_DIR)/$(IMG_PREFIX)$(if $(PROFILE),-$(PROFILE))-rootfs.tar.gz --numeric-owner --owner=0 --group=0 --sort=name -C $(TARGET_DIR)/ .
endef
E2SIZE=$(shell echo $$(($(CONFIG_TARGET_ROOTFS_PARTSIZE)*1024*1024)))