aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
commit53aef8417d5b9e00e4b74b022ed03975c732d8e9 (patch)
tree56570ca509d7826cb8163622a96ddac70562068c /include/image.mk
parentbf32023e6c902f04f995d7e787a72129794a16ba (diff)
downloadmaster-187ad058-53aef8417d5b9e00e4b74b022ed03975c732d8e9.tar.gz
master-187ad058-53aef8417d5b9e00e4b74b022ed03975c732d8e9.tar.bz2
master-187ad058-53aef8417d5b9e00e4b74b022ed03975c732d8e9.zip
Add initial version of the new Image Builder
It's still a bit rough in a few places, but it seems to work for Broadcom at least - other targets untested. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6071 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk23
1 files changed, 20 insertions, 3 deletions
diff --git a/include/image.mk b/include/image.mk
index 702434ec86..4f638f0260 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -77,10 +77,15 @@ endef
define BuildImage
download:
prepare:
-compile: compile-targets
+ifneq ($(IB),1)
+ compile: compile-targets
$(call Build/Compile)
+else
+ compile:
+endif
-install: compile install-targets
+ifneq ($(IB),1)
+ install: compile install-targets
$(call Image/Prepare)
$(call Image/mkfs/prepare)
$(call Image/BuildKernel)
@@ -88,9 +93,21 @@ install: compile install-targets
$(call Image/mkfs/squashfs)
$(call Image/mkfs/tgz)
$(call Image/mkfs/ext2)
+else
+ install: compile install-targets
+ $(call Image/BuildKernel)
+ $(call Image/mkfs/jffs2)
+ $(call Image/mkfs/squashfs)
+ $(call Image/mkfs/tgz)
+ $(call Image/mkfs/ext2)
+endif
-clean: clean-targets
+ifneq ($(IB),1)
+ clean: clean-targets
$(call Build/Clean)
+else
+ clean:
+endif
compile-targets:
install-targets: