aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-09-04 14:45:09 +0000
committerJonas Gorski <jogo@openwrt.org>2015-09-04 14:45:09 +0000
commit490b17495b54145fc7c10126f55c711af7ec0354 (patch)
treed12c3af1810a8f543c16e89c7bc114ed74d197bb /include/image.mk
parentc44193f4c781df9bbd22e9f61b3eb10cbf8ad700 (diff)
downloadmaster-187ad058-490b17495b54145fc7c10126f55c711af7ec0354.tar.gz
master-187ad058-490b17495b54145fc7c10126f55c711af7ec0354.tar.bz2
master-187ad058-490b17495b54145fc7c10126f55c711af7ec0354.zip
image: move netgear-image to top and rename to -dni
Use the same naming as netgear-chk. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46791 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 8ac3593eae..d9fa03e454 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -308,6 +308,15 @@ define Build/netgear-chk
mv $@.new $@
endef
+define Build/netgear-dni
+ $(STAGING_DIR_HOST)/bin/mkdniimg \
+ -B $(NETGEAR_BOARD_ID) -v OpenWrt.$(REVISION) \
+ $(if $(NETGEAR_HW_ID),-H $(NETGEAR_HW_ID)) \
+ -r "$(1)" \
+ -i $@ -o $@.new
+ mv $@.new $@
+endef
+
define Build/fit
$(TOPDIR)/scripts/mkits.sh \
-D $(DEVICE_NAME) -o $@.its -k $@ \