aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-03 14:44:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-03 14:44:56 +0000
commit4847a9d4459cb243b8f8c77fd03187b90a9c7777 (patch)
treee859488b53f006d13a6d6e3d2f6af84bc9efab86 /include/image.mk
parente2ee3db32f0e12356000a07cf7b3eeb9dfed9a7d (diff)
downloadmaster-187ad058-4847a9d4459cb243b8f8c77fd03187b90a9c7777.tar.gz
master-187ad058-4847a9d4459cb243b8f8c77fd03187b90a9c7777.tar.bz2
master-187ad058-4847a9d4459cb243b8f8c77fd03187b90a9c7777.zip
images imagebuilder: Allow to add sanitized extra name
For final output image names allow user to add an extra string (which is sanitized). This is particularly useful with ImageBuilder where you may generate multiple images from the same base and for the same board, with different package selections and additional files (via FILES=). Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48083 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 4ffad28bd6..cebe42e9d0 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -31,8 +31,9 @@ $(shell echo $(call tolower,$(1)) | sed 's/_/-/g')
endef
DIST_SANITIZED:=$(call sanitize,$(VERSION_DIST))
+EXTRA_NAME_SANITIZED=$(call sanitize,$(EXTRA_IMAGE_NAME))
-IMG_PREFIX:=$(DIST_SANITIZED)-$(if $(CONFIG_VERSION_FILENAMES),$(VERSION_NUMBER)-)$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))
+IMG_PREFIX:=$(DIST_SANITIZED)-$(if $(CONFIG_VERSION_FILENAMES),$(VERSION_NUMBER)-)$(if $(EXTRA_NAME_SANITIZED),$(EXTRA_NAME_SANITIZED)-)$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))
MKFS_DEVTABLE_OPT := -D $(INCLUDE_DIR)/device_table.txt