aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-10-30 22:01:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-10-30 22:01:27 +0000
commit3abad938211209a4928c088d501a4c1711ed4412 (patch)
tree246eeac62f3153c23ea5d58b06f69a5c5961d757 /include/image.mk
parentc4b2c7faf711c309f365d8c1803bd91014972047 (diff)
downloadmaster-187ad058-3abad938211209a4928c088d501a4c1711ed4412.tar.gz
master-187ad058-3abad938211209a4928c088d501a4c1711ed4412.tar.bz2
master-187ad058-3abad938211209a4928c088d501a4c1711ed4412.zip
build: make mkfs-* depend on kernel installation to fix parallel build issues
Reported-by: Petr Štetiar <ynezz@true.cz> Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47296 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index c59222e415..4e22fa59a0 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -282,7 +282,7 @@ endef
define BuildImage/mkfs
install: mkfs-$(1)
.PHONY: mkfs-$(1)
- mkfs-$(1): mkfs_prepare
+ mkfs-$(1): kernel_prepare
$(Image/mkfs/$(1))
$(call Build/mkfs/default,$(1))
$(call Build/mkfs/$(1),$(1))