aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-06-24 18:12:47 +0000
committerJohn Crispin <blogic@openwrt.org>2014-06-24 18:12:47 +0000
commit2badccb73ecc337f899f43f0be80f794e44b76d8 (patch)
treeed68a214688212417c580461d75b40db0ffcd5db /include/image.mk
parentfb4e44b207b4e0313a7ff00c39f5ad93a4f1f855 (diff)
downloadmaster-187ad058-2badccb73ecc337f899f43f0be80f794e44b76d8.tar.gz
master-187ad058-2badccb73ecc337f899f43f0be80f794e44b76d8.tar.bz2
master-187ad058-2badccb73ecc337f899f43f0be80f794e44b76d8.zip
image.mk: introduce Image/Build/UbinizeImage make target
paramters: $(1) board name $(2) ubinize-image options (e.g. --no-kernel and/or --uboot-env) $(3) rootfstype (e.g. squashfs or ubifs) $(4) kernel image file $(5) options to pass-through to ubinize (i.e. $($(PROFILE)_UBI_OPTS))) Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41311 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 66ac497849..a77de27238 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -141,6 +141,13 @@ ifneq ($(CONFIG_NAND_SUPPORT),)
(cd $(KDIR_TMP); $(TAR) cvf \
$(BIN_DIR)/$(IMG_PREFIX)-$(1)-ubi-sysupgrade.tar sysupgrade-$(1))
endef
+ define Image/Build/UbinizeImage
+ sh $(TOPDIR)/scripts/ubinize-image.sh $(2) \
+ "$(KDIR)/root.$(3)" "$(4)" \
+ "$(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(3)-ubinized.bin" \
+ $(5)
+ endef
+
endif
ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)