aboutsummaryrefslogtreecommitdiffstats
path: root/include/image.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-07 13:19:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-07 13:19:35 +0000
commit0b452f378bf397fe3825a7fa5b77354e8f64100a (patch)
tree243c0db2f615235fa32a6bf669933e790dfb0242 /include/image.mk
parent1b91aaa944317f8dba2276440dd25e38e99ab69b (diff)
downloadmaster-187ad058-0b452f378bf397fe3825a7fa5b77354e8f64100a.tar.gz
master-187ad058-0b452f378bf397fe3825a7fa5b77354e8f64100a.tar.bz2
master-187ad058-0b452f378bf397fe3825a7fa5b77354e8f64100a.zip
image: append-ubi: add optional UBI subpage size
Signed-off-by: Claudio Leite <leitec@staticky.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47411 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/image.mk')
-rw-r--r--include/image.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index a6ea8e5452..fd5e3f4b62 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -384,7 +384,8 @@ define Build/append-ubi
$(if $(KERNEL_IN_UBI),--kernel $(word 1,$^)) \
$(word 2,$^) \
$@.tmp \
- -p $(BLOCKSIZE) -m $(PAGESIZE) -E 5
+ -p $(BLOCKSIZE) -m $(PAGESIZE) -E 5 \
+ $(if $(SUBPAGESIZE),-s $(SUBPAGESIZE))
cat $@.tmp >> $@
rm $@.tmp
endef