aboutsummaryrefslogtreecommitdiffstats
path: root/include/host.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-16 07:19:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-16 07:19:45 +0000
commitac6c9d2be4a02d8e8191e9a7095f47e9051fad3b (patch)
tree17c72b94fb033fb233c65a8aa841513665b895d6 /include/host.mk
parentd3daf2103ece8f4da8e9c2e891e4b736cca2b132 (diff)
downloadmaster-187ad058-ac6c9d2be4a02d8e8191e9a7095f47e9051fad3b.tar.gz
master-187ad058-ac6c9d2be4a02d8e8191e9a7095f47e9051fad3b.tar.bz2
master-187ad058-ac6c9d2be4a02d8e8191e9a7095f47e9051fad3b.zip
detect whether the find command supports -L or -follow
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8002 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/host.mk')
-rw-r--r--include/host.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/host.mk b/include/host.mk
index 833aa83a66..cc0436e7b0 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -5,7 +5,7 @@
# See /LICENSE for more information.
#
-include $(TMP_DIR)/.host.mk
+-include $(TMP_DIR)/.host.mk
export TAR
@@ -29,6 +29,11 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
[ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar 2>/dev/null`; \
echo "TAR:=$$TAR" >> $@; \
echo "BASH:=$(shell which bash)" >> $@; \
+ if find -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
+ echo 'FIND_L=find -L $$(1)' >>$@; \
+ else \
+ echo 'FIND_L=find $$(1) -follow' >> $@; \
+ fi; \
)
endif