aboutsummaryrefslogtreecommitdiffstats
path: root/include/host.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-05 18:45:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-05 18:45:20 +0000
commita5c3c652f22fb37ef6cb5c02b059e0f2e0da78fa (patch)
tree848566631b11cd263b29f3f4755d36deb6af65e4 /include/host.mk
parentf1353fd0ffab3457334b2fd06f60351893c2130d (diff)
downloadmaster-187ad058-a5c3c652f22fb37ef6cb5c02b059e0f2e0da78fa.tar.gz
master-187ad058-a5c3c652f22fb37ef6cb5c02b059e0f2e0da78fa.tar.bz2
master-187ad058-a5c3c652f22fb37ef6cb5c02b059e0f2e0da78fa.zip
Abstracted find to $(FIND) to allow use of gfind on non-GNU systems.
Signed-off-by: Andy Boyett <agb-openwrt@padded-cell.net> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9659 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/host.mk')
-rw-r--r--include/host.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/host.mk b/include/host.mk
index d163c997dd..00eb1f55aa 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -30,6 +30,9 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
TAR=`which gtar 2>/dev/null`; \
[ -n "$$TAR" -a -x "$$TAR" ] || TAR=`which tar 2>/dev/null`; \
echo "TAR:=$$TAR" >> $@; \
+ FIND=`which gfind 2>/dev/null`; \
+ [ -n "$$FIND" -a -x "$$FIND" ] || FIND=`which find 2>/dev/null`; \
+ echo "FIND:=$$FIND" >> $@; \
echo "BASH:=$(shell which bash)" >> $@; \
if find -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
echo 'FIND_L=find -L $$(1)' >>$@; \