aboutsummaryrefslogtreecommitdiffstats
path: root/include/host.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 21:06:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 21:06:45 +0000
commit8a1b6b309826836d504effc98f554d8bc0988b60 (patch)
treeaff9fc1ec79abef6e7b1da340aadb99c6e19c285 /include/host.mk
parent11a1b240a0478c89270eac4568205cbcd037215e (diff)
downloadmaster-187ad058-8a1b6b309826836d504effc98f554d8bc0988b60.tar.gz
master-187ad058-8a1b6b309826836d504effc98f554d8bc0988b60.tar.bz2
master-187ad058-8a1b6b309826836d504effc98f554d8bc0988b60.zip
more portability fixes and a prereq check for gnu tar
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@5037 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/host.mk')
-rw-r--r--include/host.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/host.mk b/include/host.mk
index abcf045d01..3a5fd9683e 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -7,6 +7,8 @@
include $(TOPDIR)/.host.mk
+export TAR
+
$(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
@( \
HOST_OS=`uname`; \
@@ -23,5 +25,7 @@ $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
echo "TAR_WILDCARDS:=--wildcards" >> $@; \
fi; \
+ TAR=`which gtar tar | head -n 1`; \
+ echo "TAR:=$$TAR" >> $@; \
)