aboutsummaryrefslogtreecommitdiffstats
path: root/include/host.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-10 15:49:17 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-10 15:49:17 +0000
commit7ffcf90d37123e9d0063dd971b7e4e57b8125f93 (patch)
tree17e00e129201ecc746cf09ea41c449c7e5f30dd6 /include/host.mk
parent6da5c89178cbb5e3a131e5145b13bee021b1f773 (diff)
downloadmaster-187ad058-7ffcf90d37123e9d0063dd971b7e4e57b8125f93.tar.gz
master-187ad058-7ffcf90d37123e9d0063dd971b7e4e57b8125f93.tar.bz2
master-187ad058-7ffcf90d37123e9d0063dd971b7e4e57b8125f93.zip
include: export staging_dir/host/bin path from within host.mk (#18957)
We need to do that to pickup the prereq-build prepared symlinks for auxillary operations like metadata scanning. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44378 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/host.mk')
-rw-r--r--include/host.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/host.mk b/include/host.mk
index 4ca81400e9..f7368de85c 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -13,6 +13,8 @@ endif
ifneq ($(__host_inc),1)
__host_inc:=1
+export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
+
try-run = $(shell set -e; \
TMP_F="$(TMP_DIR)/try-run.$$$$.tmp"; \
if ($(1)) >/dev/null 2>&1; then echo "$(2)"; else echo "$(3)"; fi; \