aboutsummaryrefslogtreecommitdiffstats
path: root/include/host.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-09-05 16:16:59 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-09-05 16:16:59 +0000
commit607146b4f2e4e32431f42ec30a186853a4f3bfa5 (patch)
treefea483ba035a39a5f2f131b67da3dee55e5b6531 /include/host.mk
parent3c3c72e1b288fd2d940b3d7b34c9ad5c95e11527 (diff)
downloadmaster-187ad058-607146b4f2e4e32431f42ec30a186853a4f3bfa5.tar.gz
master-187ad058-607146b4f2e4e32431f42ec30a186853a4f3bfa5.tar.bz2
master-187ad058-607146b4f2e4e32431f42ec30a186853a4f3bfa5.zip
fix build error in tools on darwin on newer macs (patch by dirtyfreebooter)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22934 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/host.mk')
-rw-r--r--include/host.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/host.mk b/include/host.mk
index 02365d9eab..8092e8db77 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -32,11 +32,12 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
HOST_OS=`uname`; \
case "$$HOST_OS" in \
Linux) HOST_ARCH=`uname -m`;; \
+ Darwin) HOST_ARCH=`uname -m`;; \
*) HOST_ARCH=`uname -p`;; \
esac; \
GNU_HOST_NAME=`gcc -dumpmachine`; \
- [ -n "$$GNU_HOST_NAME" ] || \
- GNU_HOST_NAME=`$(SCRIPT_DIR)/config.guess`; \
+ [ -z "$$GNU_HOST_NAME" -o "$$HOST_OS" == "Darwin" ] && \
+ GNU_HOST_NAME=`$(TOPDIR)/scripts/config.guess`; \
echo "HOST_OS:=$$HOST_OS" > $@; \
echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \
echo "GNU_HOST_NAME:=$$GNU_HOST_NAME" >> $@; \