aboutsummaryrefslogtreecommitdiffstats
path: root/include/host.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 17:03:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 17:03:38 +0000
commit38e6843810504ab6e001ada80f0514924f25cbb7 (patch)
treecd432a8e5ce883532e8a19543f80c67e11630241 /include/host.mk
parent1da2c3fe51cd152336e4a57879faf53cc94fe3dd (diff)
downloadmaster-187ad058-38e6843810504ab6e001ada80f0514924f25cbb7.tar.gz
master-187ad058-38e6843810504ab6e001ada80f0514924f25cbb7.tar.bz2
master-187ad058-38e6843810504ab6e001ada80f0514924f25cbb7.zip
only use --wildcards for gnu tar
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@5022 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/host.mk')
-rw-r--r--include/host.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/include/host.mk b/include/host.mk
index b4580e2b7a..6458881472 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -22,3 +22,7 @@ $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
-e 's/cris.*/cris/' \
-e 's/i[3-9]86/i386/'`" >> $@
echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
+ if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
+ echo "TAR_OPTIONS+=--wildcards" >> $@; \
+ fi
+