aboutsummaryrefslogtreecommitdiffstats
path: root/include/host.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-08-17 09:04:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-08-17 09:04:48 +0000
commit34a8a11664b0e9393bd832a1de0c2d081da67ba2 (patch)
treea8ac22d61b546ad29c82fa806447a6c66350b353 /include/host.mk
parent8c1abccd9172c1d78d461e1d029a000d50578673 (diff)
downloadmaster-187ad058-34a8a11664b0e9393bd832a1de0c2d081da67ba2.tar.gz
master-187ad058-34a8a11664b0e9393bd832a1de0c2d081da67ba2.tar.bz2
master-187ad058-34a8a11664b0e9393bd832a1de0c2d081da67ba2.zip
export the FIND variable which points to a usable find version
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12327 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/host.mk')
-rw-r--r--include/host.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/include/host.mk b/include/host.mk
index 9d40ec40a3..b6a58248fd 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -8,7 +8,7 @@
TMP_DIR ?= $(TOPDIR)/tmp
-include $(TMP_DIR)/.host.mk
-export TAR
+export TAR FIND
ifneq ($(__host_inc),1)
__host_inc:=1
@@ -34,10 +34,10 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
[ -n "$$FIND" -a -x "$$FIND" ] || FIND=`which find 2>/dev/null`; \
echo "FIND:=$$FIND" >> $@; \
echo "BASH:=$(shell which bash)" >> $@; \
- if find -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
- echo 'FIND_L=find -L $$(1)' >>$@; \
+ if $$FIND -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
+ echo "FIND_L=$$FIND -L \$$(1)" >>$@; \
else \
- echo 'FIND_L=find $$(1) -follow' >> $@; \
+ echo "FIND_L=$$FIND \$$(1) -follow" >> $@; \
fi; \
if xargs --help 2>&1 | grep 'gnu.org' >/dev/null; then \
echo 'XARGS:=xargs -r' >> $@; \