aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-09-23 09:50:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-09-23 09:50:01 +0000
commitce44bef353e3ce217a6fa54af1256fa23dd9d7a6 (patch)
treefb86bbe643f26e4338fbcb9e29e039446bd66a2c /include/host-build.mk
parentc09ce574b4dd981aab263be5d3362db3195c4c90 (diff)
downloadmaster-187ad058-ce44bef353e3ce217a6fa54af1256fa23dd9d7a6.tar.gz
master-187ad058-ce44bef353e3ce217a6fa54af1256fa23dd9d7a6.tar.bz2
master-187ad058-ce44bef353e3ce217a6fa54af1256fa23dd9d7a6.zip
build: add the + token to any commands that can pass through the jobserver, fixes parallel build on some systems
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33523 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 66795c8e10..60b7b9f916 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -80,7 +80,7 @@ ifneq ($(HOST_OS),Darwin)
endif
define Host/Configure/Default
- (cd $(HOST_BUILD_DIR)/$(3); \
+ $(if $(HOST_CONFIGURE_PARALLEL),+)(cd $(HOST_BUILD_DIR)/$(3); \
if [ -x configure ]; then \
$(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/$(3)/ && \
$(2) \
@@ -97,7 +97,7 @@ define Host/Configure
endef
define Host/Compile/Default
- $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) \
+ +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) \
$(HOST_MAKE_FLAGS) \
$(1)
endef