aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-25 18:28:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-25 18:28:25 +0000
commit8a3423f044b04baf3bf52b7e349c0649098831f2 (patch)
tree0d7e068a908071989a82ba12fe682b22c68ca952 /include/host-build.mk
parent2cb1f18c15127d8611cd05038e164be12dac2ba7 (diff)
downloadmaster-187ad058-8a3423f044b04baf3bf52b7e349c0649098831f2.tar.gz
master-187ad058-8a3423f044b04baf3bf52b7e349c0649098831f2.tar.bz2
master-187ad058-8a3423f044b04baf3bf52b7e349c0649098831f2.zip
add auto-rebuild for host builds (tested with tools/ and toolchain/)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6361 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk22
1 files changed, 12 insertions, 10 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 0502d7682a..1511242f95 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -73,6 +73,15 @@ ifneq ($(strip $(PKG_SOURCE)),)
endif
define HostBuild
+ ifeq ($(DUMP),)
+ ifeq ($(CONFIG_AUTOREBUILD),y)
+ ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p $(PKG_BUILD_DIR) . $(PKG_FILE_DEPEND)),$(PKG_BUILD_DIR))
+ $$(info Forcing package rebuild)
+ $(PKG_BUILD_DIR)/.prepared: package-clean
+ endif
+ endif
+ endif
+
$(PKG_BUILD_DIR)/.prepared:
@-rm -rf $(PKG_BUILD_DIR)
@mkdir -p $(PKG_BUILD_DIR)
@@ -92,7 +101,7 @@ define HostBuild
touch $$@
ifdef Build/Install
- install-targets: $(STAGING_DIR)/stampfiles/.host_$(PKG_NAME)-installed
+ install: $(STAGING_DIR)/stampfiles/.host_$(PKG_NAME)-installed
endif
package-clean: FORCE
@@ -103,16 +112,9 @@ define HostBuild
download:
prepare: $(PKG_BUILD_DIR)/.prepared
configure: $(PKG_BUILD_DIR)/.configured
-
- compile-targets: $(PKG_BUILD_DIR)/.built
- compile: compile-targets
-
- install-targets:
- install: install-targets
-
- clean-targets:
+ compile: $(PKG_BUILD_DIR)/.built
+ install:
clean: FORCE
- @$(MAKE) clean-targets
$(call Build/Clean)
rm -rf $(PKG_BUILD_DIR)