aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-14 00:40:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-14 00:40:27 +0000
commit75d681665a26ee9733542b8e5c32e9ba1bae4dcc (patch)
tree5740afd664000225e2cfb54e51686fcf72ab0d66 /include/host-build.mk
parent96c14a07ed71679c0f58500a4e20e8f1ffe0cc41 (diff)
downloadmaster-187ad058-75d681665a26ee9733542b8e5c32e9ba1bae4dcc.tar.gz
master-187ad058-75d681665a26ee9733542b8e5c32e9ba1bae4dcc.tar.bz2
master-187ad058-75d681665a26ee9733542b8e5c32e9ba1bae4dcc.zip
move common unpacking code to unpack.mk, replace zcat with $(ZCAT) for systems that use gzcat instead
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5070 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk8
1 files changed, 2 insertions, 6 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index a1287da475..858eee5318 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -6,13 +6,9 @@
#
include $(INCLUDE_DIR)/host.mk
+include $(INCLUDE_DIR)/unpack.mk
-ifneq ($(strip $(PKG_CAT)),)
- ifeq ($(PKG_CAT),unzip)
- UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
- else
- UNPACK=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
- endif
+ifneq ($(strip $(UNPACK)),)
define Build/Prepare/Default
$(UNPACK)
@if [ -d ./patches ]; then \