aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka.perkov@sartura.hr>2016-10-09 21:16:54 +0200
committerGitHub <noreply@github.com>2016-10-09 21:16:54 +0200
commit4fd1bdc0d982ddd87b2faad6e2f3a470e5184a8c (patch)
treecb8a987eab19aa8f71d625e01ceb2dcb8e807c39 /include/host-build.mk
parent73637d4c7ee7d86352201884bf14cdd857316604 (diff)
parent8bd198f171b76b834e1462e1789ae060a42d983e (diff)
downloadmaster-187ad058-4fd1bdc0d982ddd87b2faad6e2f3a470e5184a8c.tar.gz
master-187ad058-4fd1bdc0d982ddd87b2faad6e2f3a470e5184a8c.tar.bz2
master-187ad058-4fd1bdc0d982ddd87b2faad6e2f3a470e5184a8c.zip
Merge pull request #121 from NeoRaider/build-paths
include: improve consistency of PATH etc. in host and target package builds
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index a494ceddf3..72b32597d4 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -111,7 +111,7 @@ define Host/Install/Default
endef
define Host/Install
- $(call Host/Install/Default)
+ $(call Host/Install/Default,$(HOST_BUILD_PREFIX))
endef
@@ -133,7 +133,7 @@ define Download/default
endef
define Host/Exports/Default
- $(1) : export ACLOCAL_INCLUDE=$$(foreach p,$$(wildcard $$(STAGING_DIR_HOST)/share/aclocal $$(STAGING_DIR_HOST)/share/aclocal-* $(if $(IS_PACKAGE_BUILD),$$(STAGING_DIR_HOST)/share/aclocal $$(STAGING_DIR_HOST)/share/aclocal-*)),-I $$(p))
+ $(1) : export ACLOCAL_INCLUDE=$$(foreach p,$$(wildcard $$(STAGING_DIR_HOST)/share/aclocal $$(STAGING_DIR_HOST)/share/aclocal-* $(if $(IS_PACKAGE_BUILD),$$(STAGING_DIR)/host/share/aclocal $$(STAGING_DIR)/host/share/aclocal-*)),-I $$(p))
$(1) : export STAGING_PREFIX=$$(HOST_BUILD_PREFIX)
$(1) : export PKG_CONFIG_PATH=$$(STAGING_DIR_HOST)/lib/pkgconfig:$$(HOST_BUILD_PREFIX)/lib/pkgconfig
$(1) : export PKG_CONFIG_LIBDIR=$$(HOST_BUILD_PREFIX)/lib/pkgconfig
@@ -172,8 +172,9 @@ ifndef DUMP
$(foreach hook,$(Hooks/HostCompile/Post),$(call $(hook))$(sep))
touch $$@
+ $(call Host/Exports,$(HOST_STAMP_INSTALLED))
$(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT) $(if $(FORCE_HOST_INSTALL),FORCE)
- $(call Host/Install)
+ $(call Host/Install,$(HOST_BUILD_PREFIX))
$(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
mkdir -p $$(shell dirname $$@)
touch $(HOST_STAMP_BUILT)