aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2010-03-05 20:15:12 +0000
committerTravis Kemen <thepeople@openwrt.org>2010-03-05 20:15:12 +0000
commit47a3a62caac4166638a50a56bd36736c0c4bd46b (patch)
treef24b6c4cc9d46331842e3454c175ca77b1d5a99f /include/host-build.mk
parent5f00a9860b1c917ed918a568090f56964c271207 (diff)
downloadmaster-187ad058-47a3a62caac4166638a50a56bd36736c0c4bd46b.tar.gz
master-187ad058-47a3a62caac4166638a50a56bd36736c0c4bd46b.tar.bz2
master-187ad058-47a3a62caac4166638a50a56bd36736c0c4bd46b.zip
this patch fixes toolchain parallel build, which reduces build time.
In order to enable parallel build, change line 21 of include/host-build.mk from: override MAKEFLAGS= to: override MAKEFLAGS=$(MAKE_JOBS) -Raphael git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19995 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 6324276a70..75792579eb 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -80,7 +80,7 @@ define Host/Compile
endef
define Host/Install/Default
- $(MAKE) -C $(HOST_BUILD_DIR) install
+ $(_SINGLE)$(MAKE) -C $(HOST_BUILD_DIR) install
endef
define Host/Install