aboutsummaryrefslogtreecommitdiffstats
path: root/include/host-build.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-03-12 14:07:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-03-12 14:07:08 +0000
commit010eaaa4c2e0643e06e77ea3e6a1931e5a00a3f4 (patch)
treec451eb6208583b77b4e470654ae2984206785c55 /include/host-build.mk
parenteafe10bcdb0f318a6dae7110edfd7703994528bb (diff)
downloadmaster-187ad058-010eaaa4c2e0643e06e77ea3e6a1931e5a00a3f4.tar.gz
master-187ad058-010eaaa4c2e0643e06e77ea3e6a1931e5a00a3f4.tar.bz2
master-187ad058-010eaaa4c2e0643e06e77ea3e6a1931e5a00a3f4.zip
make the compile: host-install dependency independent of the order in which the makefiles were included
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14853 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/host-build.mk')
-rw-r--r--include/host-build.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index e92c7b3e68..a0ffd83b6e 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -122,7 +122,7 @@ ifndef DUMP
host-install: $(HOST_STAMP_INSTALLED)
endif
- download:
+ $(if $(STAMP_BUILT),compile: host-install)
host-prepare: $(HOST_STAMP_PREPARED)
host-configure: $(HOST_STAMP_CONFIGURED)
host-compile: $(HOST_STAMP_BUILT)
@@ -134,8 +134,9 @@ ifndef DUMP
endef
+ download:
prepare: host-prepare
- compile: host-compile $(if $(STAMP_BUILT),host-install)
+ compile: host-compile
install: host-install
clean: host-clean