aboutsummaryrefslogtreecommitdiffstats
path: root/include/feeds.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2016-01-24 15:36:05 +0000
committerJo-Philipp Wich <jow@openwrt.org>2016-01-24 15:36:05 +0000
commitc18a81fd6d9fffb0da4f81e557f79120c1592c89 (patch)
treee7fda7faf2c757e86ec6811f74b28ac152d26950 /include/feeds.mk
parentd49ca69e9141b4414557807f7c56cc408156b54d (diff)
downloadmaster-187ad058-c18a81fd6d9fffb0da4f81e557f79120c1592c89.tar.gz
master-187ad058-c18a81fd6d9fffb0da4f81e557f79120c1592c89.tar.bz2
master-187ad058-c18a81fd6d9fffb0da4f81e557f79120c1592c89.zip
include: group kmod ipk files into a "kernel" subdirectory
This is useful to just use the kmods from an official build while supplying base packages from a custom feed or the other way around; for just overriding the kmods with a local repo while using official repos for the rest. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48475 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/feeds.mk')
-rw-r--r--include/feeds.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index b1a8f81da9..4f71b39940 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -5,7 +5,7 @@
# See /LICENSE for more information.
#
--include $(TMP_DIR)/.packagefeeds
+-include $(TMP_DIR)/.packagesubdirs
FEEDS_AVAILABLE:=$(shell $(SCRIPT_DIR)/feeds list -n)
FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
@@ -21,7 +21,7 @@ PKG_CONFIG_DEPENDS += \
# 1: package name
define FeedPackageDir
$(strip $(if $(CONFIG_PER_FEED_REPO), \
- $(abspath $(PACKAGE_DIR)/$(if $(Package/$(1)/feed),$(Package/$(1)/feed),base)), \
+ $(abspath $(PACKAGE_DIR)/$(if $(Package/$(1)/subdir),$(Package/$(1)/subdir),base)), \
$(PACKAGE_DIR)))
endef
@@ -29,7 +29,7 @@ endef
define FeedSourcesAppend
( \
$(strip $(if $(CONFIG_PER_FEED_REPO), \
- $(foreach feed,base $(FEEDS_ENABLED),echo "src/gz %n_$(feed) %U/$(feed)";) \
+ $(foreach feed,base kernel $(FEEDS_ENABLED),echo "src/gz %n_$(feed) %U/$(feed)";) \
$(if $(CONFIG_PER_FEED_REPO_ADD_DISABLED), \
$(foreach feed,$(FEEDS_DISABLED),echo "$(if $(CONFIG_PER_FEED_REPO_ADD_COMMENTED),# )src/gz %n_$(feed) %U/$(feed)";)) \
, \