aboutsummaryrefslogtreecommitdiffstats
path: root/include/feeds.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-10-16 10:30:16 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-10-16 10:30:16 +0000
commit41f42651018420470e57ee4483db06ccad8ec0c6 (patch)
treedaefccf3d5b079cdedf80a9a4352349b64115167 /include/feeds.mk
parentb3c29f9f2368461851e80e430143ec48212db97a (diff)
downloadmaster-187ad058-41f42651018420470e57ee4483db06ccad8ec0c6.tar.gz
master-187ad058-41f42651018420470e57ee4483db06ccad8ec0c6.tar.bz2
master-187ad058-41f42651018420470e57ee4483db06ccad8ec0c6.zip
build: improve feed handling for opkg.conf
- Consider not installed feeds as well - Add option to decide whether to comment disabled feeds Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42931 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/feeds.mk')
-rw-r--r--include/feeds.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index 97b14491f0..695b03b145 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -10,10 +10,12 @@
FEEDS_AVAILABLE:=$(shell $(SCRIPT_DIR)/feeds list -n)
FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
FEEDS_ENABLED:=$(foreach feed,$(FEEDS_INSTALLED),$(if $(CONFIG_FEED_$(feed)),$(feed)))
-FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_INSTALLED))
+FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_AVAILABLE))
PKG_CONFIG_DEPENDS += \
CONFIG_PER_FEED_REPO \
+ CONFIG_PER_FEED_REPO_ADD_DISABLED \
+ CONFIG_PER_FEED_REPO_ADD_COMMENTED \
$(foreach feed,$(FEEDS_INSTALLED),CONFIG_FEED_$(feed))
# 1: package name