aboutsummaryrefslogtreecommitdiffstats
path: root/include/feeds.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-08-06 09:12:31 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-08-06 09:12:31 +0000
commit07d7a0b0cb0773c8a75c2cd44436ef0ab59775b8 (patch)
treeda36d76bf8a4548ceb7f64e572d01d3c70558f8a /include/feeds.mk
parentfdb795c3e4e73747ff722d60f2368e79b5214007 (diff)
downloadmaster-187ad058-07d7a0b0cb0773c8a75c2cd44436ef0ab59775b8.tar.gz
master-187ad058-07d7a0b0cb0773c8a75c2cd44436ef0ab59775b8.tar.bz2
master-187ad058-07d7a0b0cb0773c8a75c2cd44436ef0ab59775b8.zip
include: fix detection of installed feeds
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42003 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/feeds.mk')
-rw-r--r--include/feeds.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index 17ce64f83a..97b14491f0 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -8,8 +8,9 @@
-include $(TMP_DIR)/.packagefeeds
FEEDS_AVAILABLE:=$(shell $(SCRIPT_DIR)/feeds list -n)
-FEEDS_INSTALLED:=$(patsubst %.index,%,$(notdir $(wildcard $(TOPDIR)/feeds/*.index)))
+FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
FEEDS_ENABLED:=$(foreach feed,$(FEEDS_INSTALLED),$(if $(CONFIG_FEED_$(feed)),$(feed)))
+FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_INSTALLED))
PKG_CONFIG_DEPENDS += \
CONFIG_PER_FEED_REPO \