aboutsummaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-10-08 08:01:39 +0000
committerJohn Crispin <blogic@openwrt.org>2014-10-08 08:01:39 +0000
commit978b39ca1fc33eb071cf2518ddf2c32376d1346f (patch)
tree44ada46face1ee084ae20c93233ae142e159b312 /include/download.mk
parentb0ca0dd4b026b658c3afb198f7303fe9ad7064b4 (diff)
downloadmaster-187ad058-978b39ca1fc33eb071cf2518ddf2c32376d1346f.tar.gz
master-187ad058-978b39ca1fc33eb071cf2518ddf2c32376d1346f.tar.bz2
master-187ad058-978b39ca1fc33eb071cf2518ddf2c32376d1346f.zip
include/download.mk: Add download mirrors for tools from GNU Savannah (bug #15184)
I defined a new download method @SAVANNAH in include/download.mk and scripts/download.pl, and converted quilt and qemu to use that method. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42840 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index cc4ffb0cfb..adaa2e6ac5 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -11,7 +11,7 @@ DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
define dl_method
$(strip \
$(if $(2),$(2), \
- $(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% ftp://% http://% https://% file://%,$(1)),default, \
+ $(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% @SAVANNAH/% ftp://% http://% https://% file://%,$(1)),default, \
$(if $(filter git://%,$(1)),git, \
$(if $(filter svn://%,$(1)),svn, \
$(if $(filter cvs://%,$(1)),cvs, \