aboutsummaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorJens Muecke <jens@nons.de>2012-03-17 21:33:13 +0000
committerJens Muecke <jens@nons.de>2012-03-17 21:33:13 +0000
commit8e1dbb32a73839e972e3a16826f83faa0a3a9af1 (patch)
tree99b82ce646a32150eb34058a991fa6545333f772 /include/download.mk
parentff7240ed2bff02fb2f3552156851fd198124980d (diff)
downloadmaster-187ad058-8e1dbb32a73839e972e3a16826f83faa0a3a9af1.tar.gz
master-187ad058-8e1dbb32a73839e972e3a16826f83faa0a3a9af1.tar.bz2
master-187ad058-8e1dbb32a73839e972e3a16826f83faa0a3a9af1.zip
Enable recursive download of git sources.
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30967 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/download.mk b/include/download.mk
index 7009bfcd44..6cc10d95c3 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -87,7 +87,7 @@ define DownloadMethod/git
cd $(TMP_DIR)/dl && \
rm -rf $(SUBDIR) && \
[ \! -d $(SUBDIR) ] && \
- git clone $(URL) $(SUBDIR) && \
+ git clone $(URL) $(SUBDIR) --recursive && \
(cd $(SUBDIR) && git checkout $(VERSION)) && \
echo "Packing checkout..." && \
rm -rf $(SUBDIR)/.git && \