aboutsummaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-10-10 15:01:50 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-10-10 15:01:50 +0000
commit743a74e2a6bfb07f36bc91f79958b7a067d1190d (patch)
treefd589084560f098f0361a662690c5f558d52ee86 /include/download.mk
parent5a8864448ad4a2b391848e034e9ebca834544dfd (diff)
downloadmaster-187ad058-743a74e2a6bfb07f36bc91f79958b7a067d1190d.tar.gz
master-187ad058-743a74e2a6bfb07f36bc91f79958b7a067d1190d.tar.bz2
master-187ad058-743a74e2a6bfb07f36bc91f79958b7a067d1190d.zip
Incorrect checkout of git submodules
When checking out git packages, buildroot doesn't seem to track the revisions correctly of any submodules referenced by that project. As a result, the submodule stays at whatever revision was referenced by the head of the master branch. Running a 'git submodule update' after the checkout fixes this problem. Signed-off-by: Owen Kirby <osk@exegin.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38359 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 372db03194..1c3f23e94b 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -88,7 +88,7 @@ define DownloadMethod/git
rm -rf $(SUBDIR) && \
[ \! -d $(SUBDIR) ] && \
git clone $(URL) $(SUBDIR) --recursive && \
- (cd $(SUBDIR) && git checkout $(VERSION)) && \
+ (cd $(SUBDIR) && git checkout $(VERSION) && git submodule update) && \
echo "Packing checkout..." && \
rm -rf $(SUBDIR)/.git && \
$(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \