aboutsummaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-16 03:10:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-16 03:10:40 +0000
commit6fe9aab05af416e345d4a741f278dcb394490302 (patch)
treee4f3fafdc1028ca7b512e52d5d667b249f43f947 /include/download.mk
parent5e5f9f681022ec3984322bacf599f06b6a41f65c (diff)
downloadmaster-187ad058-6fe9aab05af416e345d4a741f278dcb394490302.tar.gz
master-187ad058-6fe9aab05af416e345d4a741f278dcb394490302.tar.bz2
master-187ad058-6fe9aab05af416e345d4a741f278dcb394490302.zip
add git checkout support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9553 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk20
1 files changed, 18 insertions, 2 deletions
diff --git a/include/download.mk b/include/download.mk
index 3866242805..3c7cb7e77b 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -46,7 +46,7 @@ endef
define DownloadMethod/svn
$(call wrap_mirror, \
- echo "Checking out files from svn repository..."; \
+ echo "Checking out files from the svn repository..."; \
mkdir -p $(TMP_DIR)/dl && \
cd $(TMP_DIR)/dl && \
rm -rf $(SUBDIR) && \
@@ -59,8 +59,24 @@ define DownloadMethod/svn
)
endef
+define DownloadMethod/git
+ $(call wrap_mirror, \
+ echo "Checking out files from the git repository..."; \
+ mkdir -p $(TMP_DIR)/dl && \
+ cd $(TMP_DIR)/dl && \
+ rm -rf $(SUBDIR) && \
+ [ \! -d $(SUBDIR) ] && \
+ git-clone $(URL) $(SUBDIR) && \
+ (cd $(SUBDIR) && git-checkout $(VERSION)) && \
+ echo "Packing checkout..." && \
+ rm -rf $(SUBDIR)/.git && \
+ $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
+ mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/; \
+ )
+endef
+
Validate/svn=VERSION SUBDIR
-#Validate/git=VERSION SUBDIR
+Validate/git=VERSION SUBDIR
define Download/Defaults
URL:=