aboutsummaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-07-12 12:18:36 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-07-12 12:18:36 +0000
commit1a1d24802c6e37790951de0e92809b2aa93242a1 (patch)
tree6587978f2397400051294e6e9b9a8ef229d3ab30 /include/download.mk
parent39ae9ac168b557237b8fff22df39df6566c87342 (diff)
downloadmaster-187ad058-1a1d24802c6e37790951de0e92809b2aa93242a1.tar.gz
master-187ad058-1a1d24802c6e37790951de0e92809b2aa93242a1.tar.bz2
master-187ad058-1a1d24802c6e37790951de0e92809b2aa93242a1.zip
SVN checkouts should be made non-interactive, so that https repositories with auto-signed repositories can be checked out without user interaction
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11785 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 0558d4979e..74986be598 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -67,7 +67,7 @@ define DownloadMethod/svn
cd $(TMP_DIR)/dl && \
rm -rf $(SUBDIR) && \
[ \! -d $(SUBDIR) ] && \
- svn co -r$(VERSION) $(URL) $(SUBDIR) && \
+ svn co --non-interactive -r$(VERSION) $(URL) $(SUBDIR) && \
find $(SUBDIR) -name .svn | xargs rm -rf && \
echo "Packing checkout..." && \
$(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \