aboutsummaryrefslogtreecommitdiffstats
path: root/include/download.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-03-20 17:18:47 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-03-20 17:18:47 +0000
commit01b98b8f2ba3551692e408266424e697b09db732 (patch)
treedae65b2bf0e8d201fe0875d8e93a65390be38158 /include/download.mk
parent826466d5c4c17932878e13a44b25493ade8d7faf (diff)
downloadmaster-187ad058-01b98b8f2ba3551692e408266424e697b09db732.tar.gz
master-187ad058-01b98b8f2ba3551692e408266424e697b09db732.tar.bz2
master-187ad058-01b98b8f2ba3551692e408266424e697b09db732.zip
fix svn download with older svn client versions
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20322 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/download.mk')
-rw-r--r--include/download.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/include/download.mk b/include/download.mk
index 4e201464b4..2d3f35fee9 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -63,6 +63,12 @@ define DownloadMethod/cvs
)
endef
+SVN_VERSION=$(shell svn --version | head -1 | awk '{ print $3 }' | cut -d. -f2)
+ifeq ($(SVN_VERSION),5)
+else
+SVN_OPTS:=--trust-server-cert
+endif
+
define DownloadMethod/svn
$(call wrap_mirror, \
echo "Checking out files from the svn repository..."; \
@@ -70,7 +76,7 @@ define DownloadMethod/svn
cd $(TMP_DIR)/dl && \
rm -rf $(SUBDIR) && \
[ \! -d $(SUBDIR) ] && \
- svn export --non-interactive --trust-server-cert -r$(VERSION) $(URL) $(SUBDIR) && \
+ svn export --non-interactive $(SVN_OPTS) -r$(VERSION) $(URL) $(SUBDIR) && \
echo "Packing checkout..." && \
$(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/ && \