aboutsummaryrefslogtreecommitdiffstats
path: root/include/depends.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-26 11:32:13 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-26 11:32:13 +0000
commitc861cd6195d04f95bb4d1c1e3313ebcbbc2dd1dd (patch)
treebadeb2edebe14ff04d3b513fc617815c87c7e4b9 /include/depends.mk
parent56f3c239abfff7eae9ae8bfa94286ba28b977db7 (diff)
downloadmaster-187ad058-c861cd6195d04f95bb4d1c1e3313ebcbbc2dd1dd.tar.gz
master-187ad058-c861cd6195d04f95bb4d1c1e3313ebcbbc2dd1dd.tar.bz2
master-187ad058-c861cd6195d04f95bb4d1c1e3313ebcbbc2dd1dd.zip
ignore filenames that can cause problems for the recursive dependency handling
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8171 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/depends.mk')
-rw-r--r--include/depends.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/depends.mk b/include/depends.mk
index 1e01d35f81..be58ed1cf0 100644
--- a/include/depends.mk
+++ b/include/depends.mk
@@ -11,9 +11,9 @@
# 3: tempfile for file listings
# 4: find options
-DEP_FINDPARAMS := -type f -not -name ".*" -and -not -path "*.svn*"
+DEP_FINDPARAMS := -type f -not -name ".*" -and -not -path "*.svn*" -type f -not -name ".*" -and -not -path "*.svn*" -and -not -path "*:*" -and -not -path "*!*" -and -not -path "* *" -and -not -path "*\\\#*"
define rdep
- $(foreach file,$(shell find $(1) $(DEP_FINDPARAMS) -and -not -path "*:*" $(4)),
+ $(foreach file,$(shell find $(1) $(DEP_FINDPARAMS) $(4)),
$(2): $(file)
$(file): ;
)