aboutsummaryrefslogtreecommitdiffstats
path: root/include/depends.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-30 23:52:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-30 23:52:17 +0000
commit2033a6135ab33724276e224c63afa5e8a0406001 (patch)
tree334cd8fa09f7ca5cc72956b65db3be3db556a0f3 /include/depends.mk
parent193971f1b843b9a2a673b95e9a9d602e78743ea7 (diff)
downloadmaster-187ad058-2033a6135ab33724276e224c63afa5e8a0406001.tar.gz
master-187ad058-2033a6135ab33724276e224c63afa5e8a0406001.tar.bz2
master-187ad058-2033a6135ab33724276e224c63afa5e8a0406001.zip
fix a rebuild bug related to quilt
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8255 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/depends.mk')
-rw-r--r--include/depends.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/include/depends.mk b/include/depends.mk
index be58ed1cf0..4819d6dfc1 100644
--- a/include/depends.mk
+++ b/include/depends.mk
@@ -19,11 +19,13 @@ define rdep
)
ifneq ($(3),)
- ifneq ($$(shell find $(1) $(DEP_FINDPARAMS) $(4) 2>/dev/null | md5s),$(if $(3),$(shell cat $(3) 2>/dev/null)))
+ ifneq ($$(shell find $(1) $(DEP_FINDPARAMS) $(4) 2>/dev/null | md5s),$(if $(3),$(shell cat $(3) || touch $(3) 2>/dev/null)))
$(2): $(3)
endif
- $(3): FORCE
- @-find $(1) $(DEP_FINDPARAMS) $(4) 2>/dev/null | md5s > $$@
endif
+
+ $(3): FORCE
+ @-find $(1) $(DEP_FINDPARAMS) $(4) 2>/dev/null | md5s > $$@
+ .PRECIOUS: $(3)
endef