aboutsummaryrefslogtreecommitdiffstats
path: root/include/depends.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:37 +0000
commit14be67809466ef612e619b7d8b1e8df42b4e075b (patch)
tree016fc4de832be636e9af52b9bebfc45308c65194 /include/depends.mk
parent6e39367d4faefe4d03e91495f9a174019bd8ddab (diff)
downloadmaster-187ad058-14be67809466ef612e619b7d8b1e8df42b4e075b.tar.gz
master-187ad058-14be67809466ef612e619b7d8b1e8df42b4e075b.tar.bz2
master-187ad058-14be67809466ef612e619b7d8b1e8df42b4e075b.zip
speed up the build system by including include/shell.sh on shell commands only where necessary
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22720 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/depends.mk')
-rw-r--r--include/depends.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/depends.mk b/include/depends.mk
index 65e9b25d5e..828ceb8564 100644
--- a/include/depends.mk
+++ b/include/depends.mk
@@ -13,7 +13,7 @@
DEP_FINDPARAMS := -x "*/.svn*" -x ".*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check"
-find_md5=find $(1) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | md5s
+find_md5=$(SH_FUNC) find $(1) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | md5s
define rdep
.PRECIOUS: $(2)