aboutsummaryrefslogtreecommitdiffstats
path: root/include/debug.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-04-03 03:40:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-04-03 03:40:01 +0000
commit8665a7edecd02bd74188f2c72249c386b480834d (patch)
tree5dfef5c754ea9d7a77de4f1875985f034295ec57 /include/debug.mk
parent6f8262a64aabf11f6ee20792009d3538acc47fe9 (diff)
downloadmaster-187ad058-8665a7edecd02bd74188f2c72249c386b480834d.tar.gz
master-187ad058-8665a7edecd02bd74188f2c72249c386b480834d.tar.bz2
master-187ad058-8665a7edecd02bd74188f2c72249c386b480834d.zip
build: undefine debug helper templates used by subdir.mk if the DEBUG variable is empty, speeds up "make prereq" by 25% when lots of packages are installed
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26434 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/debug.mk')
-rw-r--r--include/debug.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/include/debug.mk b/include/debug.mk
index faead042dc..bec74d187a 100644
--- a/include/debug.mk
+++ b/include/debug.mk
@@ -21,6 +21,8 @@ ifeq ($(DUMP),)
endif
endif
+ifneq ($(DEBUG),)
+
define debug
$$(findstring $(2),$$(if $$(DEBUG_SCOPE_DIR),$$(if $$(filter $$(DEBUG_SCOPE_DIR)%,$(1)),$(build_debug)),$(build_debug)))
endef
@@ -38,4 +40,12 @@ $(call warn,$(1),$(2),$(3) $(4))
$(4)
endef
+else
+
+debug:=
+warn:=
+debug_eval:=
+warn_eval = $(4)
+
+endif