aboutsummaryrefslogtreecommitdiffstats
path: root/include/cmake.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-08 22:54:15 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-08 22:54:15 +0000
commit9e9fee4f2ac6bf82e6e5bc5245d9d93319646a68 (patch)
tree3655c9731b982d748f25cd66bba5ba7434529e71 /include/cmake.mk
parent5eb79fdc7bafbf21075085fe8705825c28908ba8 (diff)
downloadmaster-187ad058-9e9fee4f2ac6bf82e6e5bc5245d9d93319646a68.tar.gz
master-187ad058-9e9fee4f2ac6bf82e6e5bc5245d9d93319646a68.tar.bz2
master-187ad058-9e9fee4f2ac6bf82e6e5bc5245d9d93319646a68.zip
include: cmake: prevent inclusion of rpath in binaries
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44328 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/cmake.mk')
-rw-r--r--include/cmake.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/cmake.mk b/include/cmake.mk
index 6ab628ee2e..862a6a9b3f 100644
--- a/include/cmake.mk
+++ b/include/cmake.mk
@@ -61,6 +61,7 @@ define Build/Configure/Default
-DCMAKE_INSTALL_PREFIX=/usr \
-DDL_LIBRARY=$(STAGING_DIR) \
-DCMAKE_PREFIX_PATH=$(STAGING_DIR) \
+ -DCMAKE_SKIP_RPATH=TRUE \
$(CMAKE_OPTIONS) \
$(CMAKE_SOURCE_DIR) \
)