aboutsummaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-01-31 08:15:51 +0000
committerNicolas Thill <nico@openwrt.org>2015-01-31 08:15:51 +0000
commitf380abfbc258528beb2fd5d906bc68badf99b32a (patch)
tree6de4847faf4ff2113557d627d08ad8fdf6251b59 /include/autotools.mk
parent1764dc90c62b80a637b5bdac02fcc286e141dc96 (diff)
downloadmaster-187ad058-f380abfbc258528beb2fd5d906bc68badf99b32a.tar.gz
master-187ad058-f380abfbc258528beb2fd5d906bc68badf99b32a.tar.bz2
master-187ad058-f380abfbc258528beb2fd5d906bc68badf99b32a.zip
include: improve 'gettext-version' fixup
* enclose the fixup in brackets * match anything in the call to AM_GNU_GETTEXT_VERSION * call it early (before autoreconf if both are specified) * chain a call to autoreconf since it messes with configure.ac Signed-off-by: Nicolas Thill <nico@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44225 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk24
1 files changed, 14 insertions, 10 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 7ebeff6c76..3316998dc9 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -84,14 +84,22 @@ define patch_libtool_target
endef
define gettext_version_target
- cd $(PKG_BUILD_DIR) && \
- GETTEXT_VERSION=$(shell $(STAGING_DIR_HOST)/bin/gettext -V | $(STAGING_DIR_HOST)/bin/sed -ne '1s/.* //p') && \
- $(STAGING_DIR_HOST)/bin/sed \
- -i $(PKG_BUILD_DIR)/configure.ac \
- -e "s/AM_GNU_GETTEXT_VERSION(\[.*\])/AM_GNU_GETTEXT_VERSION(\[$$$$GETTEXT_VERSION\])/g" && \
- $(STAGING_DIR_HOST)/bin/autopoint --force
+ (cd $(PKG_BUILD_DIR) && \
+ GETTEXT_VERSION=$(shell $(STAGING_DIR_HOST)/bin/gettext -V | $(STAGING_DIR_HOST)/bin/sed -ne '1s/.* //p') && \
+ $(STAGING_DIR_HOST)/bin/sed \
+ -i $(PKG_BUILD_DIR)/configure.ac \
+ -e "s/AM_GNU_GETTEXT_VERSION(.*)/AM_GNU_GETTEXT_VERSION(\[$$$$GETTEXT_VERSION\])/g" && \
+ $(STAGING_DIR_HOST)/bin/autopoint --force \
+ );
endef
+ifneq ($(filter gettext-version,$(PKG_FIXUP)),)
+ Hooks/Configure/Pre += gettext_version_target
+ ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
+ Hooks/Configure/Pre += autoreconf_target
+ endif
+endif
+
ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
Hooks/Configure/Pre += patch_libtool_target
endif
@@ -116,10 +124,6 @@ ifneq ($(filter autoreconf,$(PKG_FIXUP)),)
endif
endif
-ifneq ($(filter gettext-version,$(PKG_FIXUP)),)
- Hooks/Configure/Pre += gettext_version_target
-endif
-
HOST_FIXUP?=$(PKG_FIXUP)
HOST_LIBTOOL_PATHS?=$(if $(PKG_LIBTOOL_PATHS),$(PKG_LIBTOOL_PATHS),.)