aboutsummaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-08 11:55:41 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-08 11:55:41 +0000
commita5b5726b4c9a7040d79b39f40dbaf971db667836 (patch)
tree8daa624bd101a0dc19dffdb0ecfad85004b68b14 /include/autotools.mk
parentb68abd09c7eeacca3abf9be94321f80f66b7c290 (diff)
downloadmaster-187ad058-a5b5726b4c9a7040d79b39f40dbaf971db667836.tar.gz
master-187ad058-a5b5726b4c9a7040d79b39f40dbaf971db667836.tar.bz2
master-187ad058-a5b5726b4c9a7040d79b39f40dbaf971db667836.zip
[include] autotools.mk: remove GNUmakefile before running autoreconf (spotted libgcrypt++)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24344 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 9ba3fc33b9..a1a5d5d815 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -20,6 +20,7 @@ define autoreconf
if [ -x ./autogen.sh ]; then \
./autogen.sh || true; \
elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
+ rm -f ./GNUmakefile; \
$(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
$(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
fi \