aboutsummaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-03-29 03:38:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-03-29 03:38:40 +0000
commita2ec87dfec95123a2d8f7466664aaca262a5e4c6 (patch)
treee16bf223a95dc4185f2f35ec2bf8eb2a533a44ab /include/autotools.mk
parent62c5734bb422ba86ac5609ba7e13ef509c973e0a (diff)
downloadmaster-187ad058-a2ec87dfec95123a2d8f7466664aaca262a5e4c6.tar.gz
master-187ad058-a2ec87dfec95123a2d8f7466664aaca262a5e4c6.tar.bz2
master-187ad058-a2ec87dfec95123a2d8f7466664aaca262a5e4c6.zip
add a new helper macro to deal with conditional ./configure flags
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20570 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index e1535d0b16..c941a4949d 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -32,6 +32,7 @@ update_libtool_ucxx = \
) \
$(call update_libtool_common)
+autoconf_bool = $(patsubst %,$(if $($(1)),--enable,--disable)-%,$(2))
# prevent libtool from linking against host development libraries
define libtool_fixup_libdir