aboutsummaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-04 19:56:47 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-04 19:56:47 +0000
commita2ac1d5f6410f15bf0115403d8c386a537ec19e7 (patch)
tree7c3db28e196c0e38e99b8148802cbc819a57cae2 /include/autotools.mk
parent30b199e682450d4bbe624c27c16b18a4d1a05a86 (diff)
downloadmaster-187ad058-a2ac1d5f6410f15bf0115403d8c386a537ec19e7.tar.gz
master-187ad058-a2ac1d5f6410f15bf0115403d8c386a537ec19e7.tar.bz2
master-187ad058-a2ac1d5f6410f15bf0115403d8c386a537ec19e7.zip
[include] re-enable the libtool PKG_BUILD_DEPENDS for PKG_FIXUP and emit a deprecation warning. Packages must specify PKG_BUILD_DEPENDS:=libtool
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24246 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk23
1 files changed, 9 insertions, 14 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 20227474cb..534add6425 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -57,18 +57,13 @@ endef
Hooks/InstallDev/Post += libtool_remove_files
-# XXX the libtool fixups got deactivated in the course of switching to libtool2 in trunk XXX
-# ifneq ($(filter libtool,$(PKG_FIXUP)),)
-# PKG_BUILD_DEPENDS += libtool
-# Hooks/Configure/Pre += update_libtool remove_version_check
-# Hooks/Configure/Post += update_libtool
-# Hooks/InstallDev/Post += libtool_fixup_libdir
-# endif
-#
-# ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-# PKG_BUILD_DEPENDS += libtool
-# Hooks/Configure/Pre += update_libtool_ucxx remove_version_check
-# Hooks/Configure/Post += update_libtool_ucxx
-# Hooks/InstallDev/Post += libtool_fixup_libdir
-# endif
+ifneq ($(filter libtool,$(PKG_FIXUP)),)
+ # WARNING: the use of PKG_FIXUP is DEPRECATED
+ PKG_BUILD_DEPENDS += libtool
+endif
+
+ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
+ # WARNING: the use of PKG_FIXUP is DEPRECATED
+ PKG_BUILD_DEPENDS += libtool
+endif