aboutsummaryrefslogtreecommitdiffstats
path: root/include/autotools.mk
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2010-12-04 13:44:43 +0000
committerMirko Vogt <mirko@openwrt.org>2010-12-04 13:44:43 +0000
commit0d0efee1134c32b3a58410357d841d696ce81d1e (patch)
tree230e640b605e7c024f3138ec845913ff4a725fc5 /include/autotools.mk
parent5a0f09b837a368083e8698624a3727094ca53524 (diff)
downloadmaster-187ad058-0d0efee1134c32b3a58410357d841d696ce81d1e.tar.gz
master-187ad058-0d0efee1134c32b3a58410357d841d696ce81d1e.tar.bz2
master-187ad058-0d0efee1134c32b3a58410357d841d696ce81d1e.zip
[trunk/include/autotools.mk] ensure accidentally installed *.la-files (into $STAGING_DIR) are going to be removed afterwards - this actually should be done within respective package-Makefiles itself, however they need to stay compatible with libtool v1.5.x which is used in backfire, since it (may) require those files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24241 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include/autotools.mk')
-rw-r--r--include/autotools.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/include/autotools.mk b/include/autotools.mk
index 7e251ead53..20227474cb 100644
--- a/include/autotools.mk
+++ b/include/autotools.mk
@@ -49,6 +49,14 @@ define remove_version_check
fi
endef
+# delete *.la-files from staging_dir - we can not yet remove respective lines within all package
+# Makefiles, since backfire still uses libtool v1.5.x which (may) require those files
+define libtool_remove_files
+ find $(1) -name '*.la' | $(XARGS) rm -f
+endef
+
+Hooks/InstallDev/Post += libtool_remove_files
+
# XXX the libtool fixups got deactivated in the course of switching to libtool2 in trunk XXX
# ifneq ($(filter libtool,$(PKG_FIXUP)),)
# PKG_BUILD_DEPENDS += libtool