aboutsummaryrefslogtreecommitdiffstats
path: root/docs
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-25 13:15:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-25 13:15:57 +0000
commitcee55332f864df1ca7c37a9fd5544b1928c8faac (patch)
tree2c6d99fffa559c845f50633d419d26f8947a5def /docs
parenta7c699c112e3812509cf5e34294f89db33927d58 (diff)
downloadmaster-187ad058-cee55332f864df1ca7c37a9fd5544b1928c8faac.tar.gz
master-187ad058-cee55332f864df1ca7c37a9fd5544b1928c8faac.tar.bz2
master-187ad058-cee55332f864df1ca7c37a9fd5544b1928c8faac.zip
add html output for the documentation (using tex4ht)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6199 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'docs')
-rw-r--r--docs/Makefile19
-rw-r--r--docs/openwrt.tex2
2 files changed, 15 insertions, 6 deletions
diff --git a/docs/Makefile b/docs/Makefile
index 8c3ca646dd..359f4e6308 100644
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -1,14 +1,23 @@
-openwrt.pdf: Makefile openwrt.tex config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex
+MAIN = openwrt.tex
+DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex
+
+all:
$(MAKE) cleanup
- pdflatex openwrt.tex
- pdflatex openwrt.tex
+ latex $(MAIN)
+ $(MAKE) openwrt.pdf openwrt.html
$(MAKE) cleanup
+
+openwrt.html: $(DEPS)
+ htlatex $(MAIN)
+
+openwrt.pdf: $(DEPS)
+ pdflatex $(MAIN)
clean: cleanup
- rm -f openwrt.pdf
+ rm -f openwrt.pdf openwrt.html openwrt.css
cleanup: FORCE
- rm -f *.log *.aux *.toc *.out
+ rm -f *.log *.aux *.toc *.out *.lg *.dvi *.idv *.4ct *.4tc *.xref *.tmp *.dvi
FORCE:
diff --git a/docs/openwrt.tex b/docs/openwrt.tex
index 753ac46e93..2c07052dac 100644
--- a/docs/openwrt.tex
+++ b/docs/openwrt.tex
@@ -1,6 +1,6 @@
\documentclass[a4paper]{book}
\usepackage[latin9]{inputenc}
-\usepackage[pdftex,bookmarks=true]{hyperref}
+\usepackage[bookmarks=true]{hyperref}
\usepackage[T1]{fontenc}
\usepackage{ae,aecompl,aeguill}
\usepackage{fancyvrb}