aboutsummaryrefslogtreecommitdiffstats
path: root/docs
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-14 09:57:45 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-14 09:57:45 +0000
commitb5bb9272ee773d30c1fde2da17c087618264ab6f (patch)
tree682cca857e1946d5a258823cfa55f3c40d9daa64 /docs
parentb5f4a9f364263f9f1fdc5093b00b223154aaf5fc (diff)
downloadmaster-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.tar.gz
master-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.tar.bz2
master-187ad058-b5bb9272ee773d30c1fde2da17c087618264ab6f.zip
build: Prevent more gzip timestamps
To improve reproducibility, prevent the inclusion of timestamps in the gzip header. Signed-off-by: Reiner Herrmann <reiner@reiner-h.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46361 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'docs')
-rw-r--r--docs/adding.tex2
1 files changed, 1 insertions, 1 deletions
diff --git a/docs/adding.tex b/docs/adding.tex
index 97547ac859..7b80c0d1d6 100644
--- a/docs/adding.tex
+++ b/docs/adding.tex
@@ -556,7 +556,7 @@ include $(INCLUDE_DIR)/image.mk
define Image/BuildKernel
cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
- gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
+ gzip -9n -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
$(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma bs=65536 conv=sync
dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.gz bs=65536 conv=sync