aboutsummaryrefslogtreecommitdiffstats
path: root/docs
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-25 19:13:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-25 19:13:49 +0000
commit7bdca0197e94dcbe7371b7cf34065b6821ebdd2b (patch)
tree2d7b5797dfb326a681204ff7d16cf3d765716e7c /docs
parentc4117003c356b0c52b92342a87b8e5c66eb9c3d9 (diff)
downloadmaster-187ad058-7bdca0197e94dcbe7371b7cf34065b6821ebdd2b.tar.gz
master-187ad058-7bdca0197e94dcbe7371b7cf34065b6821ebdd2b.tar.bz2
master-187ad058-7bdca0197e94dcbe7371b7cf34065b6821ebdd2b.zip
add prereq checks for the documentation (#1400)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6365 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'docs')
-rw-r--r--docs/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/docs/Makefile b/docs/Makefile
index 359f4e6308..9e888a4af2 100644
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -1,5 +1,12 @@
+ifeq ($(TOPDIR),)
+ TOPDIR:=${CURDIR}/..
+endif
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/prereq.mk
+
MAIN = openwrt.tex
-DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex
+DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex .prereq
all:
$(MAKE) cleanup
@@ -7,6 +14,10 @@ all:
$(MAKE) openwrt.pdf openwrt.html
$(MAKE) cleanup
+.prereq:
+ $(MAKE) prereq
+ touch $@
+
openwrt.html: $(DEPS)
htlatex $(MAIN)
@@ -19,6 +30,12 @@ clean: cleanup
cleanup: FORCE
rm -f *.log *.aux *.toc *.out *.lg *.dvi *.idv *.4ct *.4tc *.xref *.tmp *.dvi
+$(eval $(call RequireCommand,pdflatex, \
+ You need to install LaTeX to build the OpenWrt documentation \
+))
+$(eval $(call RequireCommand,htlatex, \
+ You need to install tex4ht to build the OpenWrt documentation \
+))
FORCE:
.PHONY: FORCE