aboutsummaryrefslogtreecommitdiffstats
path: root/docs
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-08-04 11:58:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-08-04 11:58:31 +0000
commit48acfc25685a902044f7d3d3ace86a1e0b7bc66d (patch)
treee0e0e2f5590fdf16285f8af534aff1479fc73be2 /docs
parentb11183f8b0f49165f0c841dd3643b8015525bd79 (diff)
downloadmaster-187ad058-48acfc25685a902044f7d3d3ace86a1e0b7bc66d.tar.gz
master-187ad058-48acfc25685a902044f7d3d3ace86a1e0b7bc66d.tar.bz2
master-187ad058-48acfc25685a902044f7d3d3ace86a1e0b7bc66d.zip
fix a few overfull hboxes, remove some redundant stuff
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8341 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'docs')
-rw-r--r--docs/adding.tex2
-rw-r--r--docs/build.tex23
-rw-r--r--docs/config.tex7
3 files changed, 12 insertions, 20 deletions
diff --git a/docs/adding.tex b/docs/adding.tex
index b1712ac9d2..2b47e6a328 100644
--- a/docs/adding.tex
+++ b/docs/adding.tex
@@ -357,7 +357,7 @@ firmware image and flash is structured. You will find below a commented example
that covers the case of the device where the bootloader can pass to the kernel its partition plan.
First of all, you need to make your flash map driver be visible in the kernel
-configuration options, this can be done by editing the file
+configuration options, this can be done by editing the file \
\textbf{linux/drivers/mtd/maps/Kconfig}:
\begin{verbatim}
diff --git a/docs/build.tex b/docs/build.tex
index 03bd1a9675..c45b905040 100644
--- a/docs/build.tex
+++ b/docs/build.tex
@@ -202,12 +202,6 @@ simplifies the entire ordeal.
Here for example, is \texttt{package/bridge/Makefile}:
\begin{Verbatim}[frame=single,numbers=left]
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
# $Id: Makefile 5624 2006-11-23 00:29:07Z nbd $
include $(TOPDIR)/rules.mk
@@ -229,12 +223,14 @@ define Package/bridge
SECTION:=net
CATEGORY:=Base system
TITLE:=Ethernet bridging configuration utility
- DESCRIPTION:=\
- Manage ethernet bridging: a way to connect networks together to \\\
- form a larger network.
URL:=http://bridge.sourceforge.net/
endef
+define Package/bridge/description
+ Manage ethernet bridging:
+ a way to connect networks together to form a larger network.
+endef
+
define Build/Configure
$(call Build/Configure/Default, \
--with-linux-headers="$(LINUX_DIR)" \
@@ -384,12 +380,6 @@ For external kernel modules, you can add them to the build system just like if t
Here for instance the Makefile for the I2C subsytem kernel modules :
\begin{Verbatim}[frame=single,numbers=left]
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
# $Id $
I2CMENU:=I2C Bus
@@ -398,8 +388,7 @@ define KernelPackage/i2c-core
TITLE:=I2C support
DESCRIPTION:=Kernel modules for i2c support
SUBMENU:=$(I2CMENU)
- KCONFIG:=$(CONFIG_I2C_CORE) \
- $(CONFIG_I2C_DEV)
+ KCONFIG:=CONFIG_I2C_CORE CONFIG_I2C_DEV
FILES:=$(MODULES_DIR)/kernel/drivers/i2c/*.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,50,i2c-core i2c-dev)
endef
diff --git a/docs/config.tex b/docs/config.tex
index f3802198ed..d13297c4f7 100644
--- a/docs/config.tex
+++ b/docs/config.tex
@@ -61,8 +61,11 @@ You can access already processed options with the \texttt{config\_get} command
Syntax:
\begin{Verbatim}
-config_get <section> <option> # prints the value of the option
-config_get <variable> <section> <option> # stores the value inside the variable
+# print the value of the option
+config_get <section> <option>
+
+# store the value inside the variable
+config_get <variable> <section> <option>
\end{Verbatim}
In busybox ash the three-option \texttt{config\_get} is faster, because it does not