aboutsummaryrefslogtreecommitdiffstats
path: root/config
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-04 23:30:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-04 23:30:36 +0000
commit99ba1f47bc96f10c3d97ce62b3ce25af94afe0a2 (patch)
treef890ca886e8b6beb85b7ce35e505811683c6fdbf /config
parent0a46a2508cab4078ca0768ef6b31c13c8be5c9f5 (diff)
downloadmaster-187ad058-99ba1f47bc96f10c3d97ce62b3ce25af94afe0a2.tar.gz
master-187ad058-99ba1f47bc96f10c3d97ce62b3ce25af94afe0a2.tar.bz2
master-187ad058-99ba1f47bc96f10c3d97ce62b3ce25af94afe0a2.zip
Configure IPv6 kernel options in config/Config-kernel.in
Revision 46834 changed IPv6 support from a module to builtin. But since the configuration of the IPv6 kernel options was left in package/kernel/linux/modules/netsupport.mk, this means that an empty kmod-ipv6 module was still being generated (not packaged). This patch moves the configuration of the IPv6 kernel options to config/Config-kernel.in to remove this last bit of the module. Note that CONFIG_IPV6_PRIVACY was dropped (enabled by default since Linux v3.13), so this option is no longer needed. See https://github.com/torvalds/linux/commit/5d9efa7ee99eed58388f186c13cf2e2a87e9ceb4 Signed-off-by: Arjen de Korte <arjen+openwrt@de-korte.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48132 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'config')
-rw-r--r--config/Config-kernel.in23
1 files changed, 23 insertions, 0 deletions
diff --git a/config/Config-kernel.in b/config/Config-kernel.in
index 4be5f53b51..6e79bae34b 100644
--- a/config/Config-kernel.in
+++ b/config/Config-kernel.in
@@ -551,3 +551,26 @@ config KERNEL_SECCOMP
default n
help
Build kernel with support for seccomp.
+
+#
+# IPv6 configuration
+#
+
+config KERNEL_IPV6
+ def_bool IPV6
+
+if KERNEL_IPV6
+
+ config KERNEL_IPV6_MULTIPLE_TABLES
+ def_bool y
+
+ config KERNEL_IPV6_SUBTREES
+ def_bool y
+
+ config KERNEL_IPV6_MROUTE
+ def_bool y
+
+ config KERNEL_IPV6_PIMSM_V2
+ def_bool n
+
+endif