aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-06-09 15:38:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-06-09 15:38:45 +0000
commitf4e7bdac427e5cf7c06378fdb68e6f1780bcaff4 (patch)
treebeda70cdc408c3248d07dec3bf53f7170d5623c2 /Makefile
parentef36c74b06f8fdc5d4e81b1bdfc1e3ad275e560f (diff)
downloadmaster-187ad058-f4e7bdac427e5cf7c06378fdb68e6f1780bcaff4.tar.gz
master-187ad058-f4e7bdac427e5cf7c06378fdb68e6f1780bcaff4.tar.bz2
master-187ad058-f4e7bdac427e5cf7c06378fdb68e6f1780bcaff4.zip
large improvement for parallel builds. works without V=99 now and without warnings. tested with -j on an 2x dual core opteron machine
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11414 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 8b0ef0d57d..72b24d14e7 100644
--- a/Makefile
+++ b/Makefile
@@ -16,6 +16,12 @@ world:
include $(TOPDIR)/include/host.mk
ifneq ($(OPENWRT_BUILD),1)
+ # XXX: these three lines are normally defined by rules.mk
+ # but we can't include that file in this context
+ empty:=
+ space:= $(empty) $(empty)
+ _SINGLE=MAKEFLAGS=$(space)
+
override OPENWRT_BUILD=1
export OPENWRT_BUILD
include $(TOPDIR)/include/debug.mk
@@ -44,7 +50,7 @@ $(BUILD_DIR)/.prepared: Makefile
clean: FORCE
rm -rf $(BUILD_DIR) $(BIN_DIR)
- $(MAKE) target/linux/clean
+ $(SUBMAKE) target/linux/clean
dirclean: clean
rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST)
@@ -55,7 +61,7 @@ prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;
prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
- $(MAKE) package/index
+ $(SUBMAKE) package/index
# update all feeds, re-create index files, install symlinks
package/symlinks: