aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-05-30 18:55:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-05-30 18:55:52 +0000
commitf45baccdc5081fc6245c9d567ddb47518f3dc84b (patch)
treedce7c27a867c504bd1f1509244405407154d9da9 /Makefile
parent8fcedabfaf95affbbba45bfdbf2627e92fa52ccd (diff)
downloadmaster-187ad058-f45baccdc5081fc6245c9d567ddb47518f3dc84b.tar.gz
master-187ad058-f45baccdc5081fc6245c9d567ddb47518f3dc84b.tar.bz2
master-187ad058-f45baccdc5081fc6245c9d567ddb47518f3dc84b.zip
improve dependency handling, fix some package makefile bugs
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3843 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 8a2e6bbb8e..f93b008033 100644
--- a/Makefile
+++ b/Makefile
@@ -70,10 +70,10 @@ config: scripts/config/conf
config-clean:
$(MAKE) -C scripts/config clean
-package/%:
+package/%: .pkginfo
$(MAKE) -C package $(patsubst package/%,%,$@)
-target/%:
+target/%: .pkginfo
$(MAKE) -C target $(patsubst target/%,%,$@)
toolchain/%: