aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-05-28 18:40:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-05-28 18:40:37 +0000
commitb1f42563ce0fdcc57066202b8b33c4da71d3907f (patch)
treea9b503ac8f6ec870ae3a57f143ef219a0de8cedd /Makefile
parentc0fdd94fc281afda4b58676d7ab19ff79b72dcfc (diff)
downloadmaster-187ad058-b1f42563ce0fdcc57066202b8b33c4da71d3907f.tar.gz
master-187ad058-b1f42563ce0fdcc57066202b8b33c4da71d3907f.tar.bz2
master-187ad058-b1f42563ce0fdcc57066202b8b33c4da71d3907f.zip
add a "make prepare" target which builds everything up to target/compile, useful for scripts/deptest.sh
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16153 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 6cf4a4b1e0..db79274c9a 100644
--- a/Makefile
+++ b/Makefile
@@ -48,6 +48,8 @@ $(BUILD_DIR)/.prepared: Makefile
@mkdir -p $$(dirname $@)
@touch $@
+prepare: $(target/stamp-compile)
+
clean: FORCE
$(_SINGLE)$(SUBMAKE) target/linux/clean
rm -rf $(BUILD_DIR) $(BIN_DIR) $(BUILD_LOG_DIR)